4th September 2018

Sock control panel and mail infrastructure Issues on one of our e-mail servers

Due to issues on one of our e-mail servers, part of the mailboxes managed by Sock are currently unreachable. We're working to resolve the issue.

Update 00:57

Mail service is available again. Not all e-mails that were received today are available yet, we're working to bring all mails back as soon as possible.

Update 13:51

We have recovered the missing e-mail messages (mail that was received yesterday) and are working to get them back into the mailboxes.

Update 6 sept 11:00

All missing e-mail messages have been returned to their mailbox.