13th February 2018

Cloud Infrastructure Issue on one of our Xen hypervisors

Due to an issue on one of our Xen hypervisors a few virtual machines are currently offline. We're working to fix this issue as soon as possible.

Update 18:50

Most virtual machines are operational again, we're working on the remaining VMs.

Update 19:00

Our hypervisor is back online and so are all VM's on the affected hypervisor.