6th June 2017

Network maintenance, scheduled 1 year ago

We will be performing upgrades to the network in the LCL datacenter.

We will be replacing parts of the core infrastructure with more powerfull equipment. This will open the possibilities to link our network to the Intelligent backbone in the near future.

While we do our utmost best to minimize the impact, some short interruptions (less than a minute) on the network are to be expected, as we need to move some physical links near the end of the maintenance.

Update 10u15

This end our maintenance. We finished the reconfiguration, and fixed two issues that popped up in the end.

Update 04:55

This phase took longer than planned due to a faulty switch. A single port misbehaved, but looked normal. It took a while to identify the exact issue and location. Servers connected to this switch will have suffered more downtime than planned. All other switches went well once the problem was resolved.

This ends the critical phases. We will now continue with the cleanup, reverting some of the shortcuts placed at the start and running a thorough verification of every component and config line. After that, the old equipment will be powered down and physically removed. This should normally not impact the network.

Update 01:22

The last critical phase has begun. Some physical links need to be replugged from the old equipment to the new. This will introduce a short interruption, as the old protocol isn't compatible with the new.

Update 23:23

A second critical phase is starting. The config will be changed step-by-step, so the traffic is handled by the new equipment. This might impact the network slightly when the changes are done, as we need to disable the config on the old equipment and enable it on the new. This is a manual process. We expect downtimes of maximum a couple of seconds on some connections.

Everything went as planned. We encountered small issues, but all of them were resolved quickly.

Update 22:43

Everything went as planned. There was a short interruption towards the Ghent datacenter, as was expected. The interruption was less than a minute. We continue the works with the next phase.

Update 22:20

The equipment is installed and powered, and the configs have been checked.

We are entering a critical phase. The new equipment will be linked to the network, and the needed routing rules will be added. Both new and old equipment should then be able to communicate with each other.

Update 22:10

The network upgrade has started. We will keep you informed of the progress through this page.

The first step is the physical installation of the new equipment, and putting some shortcuts and safeguards in our network to ease the migration. This should have no impact.