19th May 2017

Let's Encrypt outage

Let's Encrypt is having issues with their entire infrastructure. This means we currently can't (and won't even try to) issue, validate, revoke or replace Let's Encrypt SSL certificates. The existing certificates still work, and we usually renew certs 30 days before their expiry date, so no existing Let's Encrypt sites are affected.

However, should you require a new certificate before the weekend, we recommend you contact support and order a "commercial" DV cert...

Here's a link to the Let's Encrypt status page: https://letsencrypt.status.io

Update @ 15:50 CEST Although LE's status page starts te show more green than red, we are still experiencing issues with their API. We'll keep our LE workers offline at the moment..

Update Sunday morning After watching the last few updates carefully, it seems the LE service is running stable again.