14th October 2016

UPDATE: Globalsign certificate warnings

Globalsign intermediate certificates have been replaced. Browser warnings should now disappear. According to Globalsign, the issue should be resolved completely by monday.

In case you use a Globalsign certificate on servers not managed by Openminds, please download your updated certificate files from Sock.