10th April 2015

Network Incoming DDOS

At this moment we are experiencing a DDoS attack. We are investigating in order to resolve this as soon as possible.

Update: The attack is under control, we will keep an eye on it.

Update: The attack has been mitigated over the weekend, and all systems are fully functional since saturday. We'll close this incident.